Experiencing performance degradation
Incident Report for Storm Commerce
Resolved
The immediate problem has been resolved and the APIs are back to normal response times. The problem was caused by an increasing amount of requests to StormQuery which caused performance degradations for all customers. Those requests are currently blocked and we're working on analyzing why the request required the number of resources it did to affect other customers.

The API's were back to normal at ca 9:20.
Posted May 03, 2022 - 10:59 CEST
Update
We are continuing to investigate the problem, customer's might experience HTTP 403 errors on requests to StormQuery periodically.
Posted May 03, 2022 - 09:04 CEST
Update
We've experiencing an extremely high load on StormQuery, which may be part of the problem, and Storm Admin is seriously affected.
Posted May 03, 2022 - 07:56 CEST
Investigating
We’re currently experiencing performance degradations on StormAPI and Query, we’re investigating.
Posted May 03, 2022 - 07:30 CEST
This incident affected: Norce Merchant Center [Storm], Storm API, and Storm Query.