Increased Loading Times

Incident Report for Storm Commerce

Resolved

The incident affecting loading times has been fully resolved as of 08:20, and all systems are now operating normally.

We sincerely apologize for any disruption this may have caused and want to thank you for your patience and understanding while we worked to restore full performance.
Posted Sep 02, 2025 - 08:32 CEST

Investigating

We are currently experiencing slower than normal loading times. Our team is actively investigating the issue and working to restore full performance as quickly as possible.

We sincerely apologize for the inconvenience this may cause and truly appreciate your patience and understanding while we work on a resolution.

We will provide updates here as soon as more information becomes available.
Posted Sep 02, 2025 - 08:21 CEST