Storm Azure Environment is experiencing major issue

Incident Report for Storm Commerce

Resolved

The problem have been resolved. We will return with a post mortem on Monday which will be published here.
Posted Aug 30, 2025 - 15:44 CEST

Monitoring

A fix have been implemented and we continue to monitor.
Posted Aug 30, 2025 - 13:07 CEST

Identified

We are continuing to investigate the issue, we have however been able to remedy some of the issues and Norce Admin and StormApi are beginning to recover.
Posted Aug 30, 2025 - 12:45 CEST

Investigating

We're investigating.
Posted Aug 30, 2025 - 12:36 CEST
This incident affected: Norce Merchant Center [Storm], Storm API, Storm Connect, Storm Query, and Storm Event.