Connect performance issues
Incident Report for Storm Commerce
Resolved
We've solved the most critical problems causing the issues we've encountered.
Posted Oct 14, 2020 - 13:46 CEST
Investigating
We're currently experiencing intermittent performance issues in Storm Connect, we're investigating and working on mitigating the effects.
Posted Oct 14, 2020 - 10:33 CEST
This incident affected: Storm Connect.