StormApi on Azure: Performance issues and timeouts
Incident Report for Storm Commerce
Resolved
The problem have been resolved, one of the nodes running StormApi started "misbehaving" and returned very long response times and timeouts. Since most of the requests were directed to the other nodes the problem wasn't caught early enough in our monitoring. The development team are investigating the cause of the bad behaviour and the monitoring setup have been updated to capture problems like this.
Posted Mar 18, 2024 - 11:30 CET
Monitoring
A fix have been implemented and StormApi is returning to normal. We continue to monitor closely.
Posted Mar 18, 2024 - 08:52 CET
Investigating
We're experiencing problems with StormApi on Azure. We're investigating.
Posted Mar 18, 2024 - 08:29 CET
This incident affected: Storm API.